ScriptCryptor: What's this?

What's this? ScriptCryptor Help
 Revision 1.1

ScriptCryptor lets you quickly produce standalone, royalty free applications from your VBS or JS files. VBScript or JScript files will be converted into EXE files, the source of your scripts will be encrypted with Blowfish algorithm. Once converted, they cannot be modified or viewed by other users.

Main features

  • Convert Javascript and VBScript to console or windowed programms
  • No temporary file will be created while executing.
  • Command-line compilation
  • Hides and protects sources of a script from viewing.
  • Highlight command's syntaxis inside built-in editor
  • Allows you to use your own Icon and Version Info for compiled files.
  • Built-in WScript object
  • Script become independent Win32 executables, without relying on "cscript.exe" or "wscript.exe"

©2001- AbyssMedia.com. All Rights Reserved.


ScriptCryptor: System Requirements

System Requirements ScriptCryptor Help
Software Requirements:

  • Windows 95, 98, Windows NT 4.0, Windows 2000, Windows ME or Windows XP
  • Version 4.72 or later of the Windows Common Control library. This library is part of Windows 98, Microsoft Internet Explorer 4.0, and is available as a separate download from the Microsoft web site at http://www.microsoft.com/msdownload/ieplatform/ie/comctrl.asp

Hardware Requirements:

  • Pentium processor based IBM PC compatible computer (or higher)
  • 16 Mb RAM
  • About 2 MB of free hard disk space
  • VGA Video
  • Mouse


ScriptCryptor: Command Line

Command Line ScriptCryptor Help
Does ScriptCryptor support command line parameters?
Yes, you can load script from command line:

ScriptCryptor.exe "script file name"

You can start compilation from command line too:

ScriptCryptor.exe "input script file name" "output exe file name"


ScriptCryptor: Script Examples

Script Examples ScriptCryptor Help

Copy File

Set fso = CreateObject("Scripting.FileSystemObject")
fso.CopyFile "c:\mydir\*.*", "d:\backup\",TRUE

Print File

' Word need to be installed on this machine
Dim DocToPrint, oWord, oDoc
DocToPrint = "C:\MyFile.Doc"
Set oWord = CreateObject("Word.Application")
Set oWordActiveDoc = oWord.Documents.Open("" & DocToPrint)
oWordActiveDoc.PrintOut

Set oWord = Nothing
WScript.Quit(0)

Run External Application

Dim WSHShell
Set WSHShell = WScript.CreateObject("WScript.Shell")

' open maximized and wait
WSHShell.Run "notepad.exe", 3, true
' open minimized and wait
WSHShell.Run "notepad.exe", 2, true
' open normal and don't wait
WSHShell.Run "notepad.exe", 1, false

Set WSHShell = Nothing
WScript.Quit(0)

Send Email

Dim ToAddress, MessageSubject, MessageBody, MessageAttachment
Dim ol, ns, newMail

ToAddress = "John Smith"
MessageSubject = "Write the subject here"
MessageBody = "Write the message body here"

Set ol = WScript.CreateObject("Outlook.Application")
Set ns = ol.getNamespace("MAPI")
ns.logon "","",true,false
Set newMail = ol.CreateItem(olMailItem)
newMail.Subject = MessageSubject
newMail.Body = MessageBody & vbCrLf

' Validate the recipient, just in case...
Set myRecipient = ns.CreateRecipient(ToAddress)
myRecipient.Resolve
If Not myRecipient.Resolved Then
   MsgBox "unknown recipient"
Else
   newMail.Recipients.Add(myRecipient)
   newMail.Send
End If

Set ol = Nothing

Write to a file

Dim objFileSystem, objOutputFile
Dim strOutputFile

Set objFileSystem = CreateObject("Scripting.fileSystemObject")
Set objOutputFile = objFileSystem.CreateTextFile("C:\test.txt", TRUE)

objOutputFile.WriteLine("Hello world (" & Now & ")")
objOutputFile.Close

Set objFileSystem = Nothing

WScript.Quit(0)


ScriptCryptor: Limitation Before Registration

Limitation Before Registration ScriptCryptor Help

ScriptCryptor is shareware, which means that you can use it freely for evaluate purpose with small reminder screen in compiled files. If you want use complete functionality, please register your copy.

Benefits of Registration:
  • We will send you the Registration Code by email immediately.
  • As soon as you registered ScriptCryptor shareware, you will use it without any functions limited.
  • Lifetime free updates.
  • Priority support and fixes.
  • Whenever you encounter technical problems, our engineers will be available for help. Technical support is totally free.
  • More other valuable services ...


ScriptCryptor: How to register

How to register ScriptCryptor Help

You will get a registration code from us after you ordered ScriptCryptor.

Enter you registration name and code following these steps:

  • Running ScriptCryptor
  • Select "About" menu
  • Select "Register" menu item
  • Input your name and code exactly as what you've got.

Please copy and paste the registration name and code to the registration dialog and DON'T type it manually because it's difficult to distinguish the letter "l" (lower case of "L") from "1" (one) and "o" from "0" (zero), etc.
  • Press "Register" button

When the registration information was accepted, you can access the full functions of ScriptCryptor.

If you have any problem, please fell free to contact us by sending e-mail to: sales@abyssmedia.com


ScriptCryptor: How to purchare

How to purchase ScriptCryptor Help
ScriptCryptor is distributed on "try before you buy" principle. The free trial version allows you to completely evaluate the program features before registering it but with small registration reminder in all compiled file. The registration fee for ScriptCryptor is only $54.95.

You can choose one of the following easy methods of payment for registration:
Click here to register ScriptCryptor with our partner - RegNow online service.

After you purchase the ScriptCryptor, you receive your personal license key that removes all trial limitations of the program. The key and instructions will be delivered by e-mail.

Registration problems? Mail us.


ScriptCryptor: Lost Key?

Lost Key? ScriptCryptor Help
If for any reason your registration code becomes invalid or lost just send an e-mail to AbyssMedia.com at support@abyssmedia.com together with the details of your previous registration. You will receive a new code via e-mail at no charge as soon as I has validated your old registration data.


ScriptCryptor: License Agreement

License Agreement ScriptCryptor Help
ScriptCryptor, Version 2.xx
Copyright (C) 2001-2008 AbyssMedia.com

LICENSE AGREEMENT

The ScriptCryptor is shareware. This means:
  • All copyrights to ScriptCryptor are exclusively owned by AbyssMedia.com
  • This is not free software. You are hereby licensed to use this software for evaluation purposes without charge with small reminder in compiled files. If you want use this software without limitations a registration fee of $54.95 is required.
  • One registered copy of ScriptCryptor may either be used by a single person who uses the software personally on one or more computers, or installed on a single workstation used nonsimultaneously by multiple people, but not both.
  • The ScriptCryptor unregistered shareware version may be freely distributed, provided the distribution package is not modified. You are hereby licensed to make as many copies of the evaluation version of ScriptCryptor as you wish. Give exact copies of the original evaluation version to anyone, and distribute the evaluation version of ScriptCryptor in its unmodified form via electronic means. There is no charge for any of the above.
  • The registered version of ScriptCryptor may not be rented or leased, but may be permanently transferred, if the person receiving it agrees to terms of this license.
  • ScriptCryptor IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.
  • You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and civil prosecution.
  • Installing and using ScriptCryptor signifies acceptance of these terms and conditions of the license.
  • If you do not agree with the terms of this license you must remove ScriptCryptor files from your storage devices and cease to use the product.
  • AbyssMedia.com hereby represents and warrants that:
    • it has title to the ScriptCryptor and has the right to grant this license to you;
    • the granting of this license will not infringe any patent, copyright, trade-mark, trade secret or other proprietary right of any person.
    • it shall deliver the ScriptCryptor to you in proper working order free from all defects in material and workmanship, and that such Software will perform in accordance with its specification;
    • all maintenance and support services provided by AbyssMedia.com shall be performed in a diligent and professional manner by duly trained employees of AbyssMedia.com that have the requisite experience to provide the required services;
    • the ScriptCryptor does not and will not contain any backdoor, time bomb, drop dead device or other software routine designed to disable the Program automatically, with the passage of time or under the positive control of any person other than you; and
    • the ScriptCryptor does not and will not contain any virus, Trojan horse worm or other software routines designed to disable, erase or otherwise harm the Software, your hardware or data or permit unauthorized access or to perform any similar actions.


ScriptCryptor: Contacts

Contacts ScriptCryptor Help
Before you contact us, be sure to answer the following:

  • Look over what you are doing again and be sure you didn't miss a step or are doing something wrong. We can all be a bit inattentive at times.
  • If that doesn't work, take a look at our help file, it may already contain the answer to your question. Many people have "How To" questions, which can be already found there.
  • If you don't find your answer there, visit our download page. You will find the newest version of our product there. If a serious bug has been found in our program and the new version is not ready yet, we will be happy to do a "hot fix" for it.
  • Visit our support forums
  • If you still have a problem, contact technical support.

If ask for technical support or report bugs, please kindly tell us some information about product version ,windows version etc.

Support E-mails:

Technical support: | support@abyssmedia.com
Sales and orders support: | sales@abyssmedia.com

We will reply to every email from our customers!